Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-83543

Workflow on a web content folder gets lost when staging is enabled

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Duplicate
    • Affects Version/s: 7.0.X, 7.1.X, Master
    • Fix Version/s: None
    • Component/s: Staging
    • Labels:

      Description

      When enabling staging on a site which contains a folder with a workflow, the workflow isn't transferred to the staging site, so the folder no longer has workflow enabled.

      Steps to Reproduce
      1. Start up portal
      2. Create a folder under web content section under a site
      3. Configure the simple single approver workflow on the folder created in #2
      4. Go to Publishing > Staging menu and enable local staging with web content staged data enabled
      5. Check workflow configuration between staging and live site (on the same folder in web content section) 
      Expected Behavior: Single approver workflow is still selected
      Actual Behavior: Single approver workflow is no longer selected

      Testing
      Reproduced in 7.0.x-private: d0f9632e40ed47b6189a0d406422980f75ba7589
      Reproduced in master: 955ef007159b57294d6b70dd4338269843f05979

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mate.thurzo Mate Thurzo (Inactive)
                Reporter:
                christopher.kian Christopher Kian
                Participants of an Issue:
                Recent user:
                Angelo Jefferson
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  1 year, 25 weeks, 4 days ago

                  Packages

                  Version Package