Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-84033

Portal name in the Setup Wizard should be a required field

    Details

      Description

      Site Name is NOT a required field when creating a site. Currently we allow users to put an empty string for this field, resulting in some UI inconsistencies in portal.

      Steps to reproduce:

      1. Start portal with setup.wizard.enabled=true
      2. Remove Liferay from the "Portal Name" field
      3. Click 'Finish Configuration'

      Expected result:
      User cannot finish setup. Data validation message appears below the field.

      Actual result:
      Setup finishes. Default site has an empty name. Some UI inconsistencies (since areas in portal that display the site name expect text).

      I was only able to reproduce this when English was the default language. Nothing happened when submitting the form while the Portal Name field was blank and a non-English language was in use.

      Reproduced on:
      master Git ID: dd5007a8515fd7aa55ca38a6b77fc0e4b2779759
      7.1.x Git ID: 918d70966544859d13132b13358c323d1d1bac3d
      DXP 7.1 GA1

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  9 weeks, 3 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP85
                  7.0.X
                  7.1.10 DXP FP1
                  7.1.1 CE GA2
                  7.1.10.1 SP1
                  7.1.X
                  Master