Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-84262

Missing references to a preloaded web content doesn't work

    Details

      Description

      Missing references to a preloaded web content doesn't work because current code search it filtering by version=0.0, see:

      Steps to reproduce

      1. Go to Global site, webcontent section
      2. Import Web_Content-201808081454.portlet.lar file with preloaded wc
      3. Create a site
      4. Import Public_Pages-20180808143923042.lar that contains a missing reference to preloaded web content
        • Expected behavior: LAR is imported, no error is displayed
        • Wrong behavior: LAR is not imported, a missing reference error is displayed

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              lu.liu Lu Liu
              Reporter:
              jorge.diaz Jorge Diaz
              Participants of an Issue:
              Recent user:
              Csaba Turcsan
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 29 weeks, 4 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP58
                  7.0.0 DXP SP9
                  7.0.X
                  7.1.X
                  Master