Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-84596

Update AMD loader version to 2.3.1 in 7.0.x

Details

    Description

      This originates in https://issues.liferay.com/browse/LPP-31143 and applies the fix in https://issues.liferay.com/browse/LPS-84568 to the 7.0.x branch.

      Because the issue is caused by the AMD loader, there's nothing to fix in the portal, as the problem is in a third party dependency.

      Because the 7.0.x branch of the portal points to the 2.x branch of the loader but it is already releasing 3.x versions, we have decided to make two fix versions for the LPP: one in the loader's 2.x branch, another in the loader's 3.x branch.

      Because the 7.0 portal points to the 2.x AMD loader, we need to "backport" master's fix (LPS-84568) with another LPS (this) that does the same thing (changing AMD loader's version) but pointing to a different version number.

      Steps to reproduce:

      1. Follow reproduction steps in https://issues.liferay.com/browse/LPP-31143

      Expected Behavior:

      1. Portlet renders on page and no errors are thrown

      Actual Behavior:

      1. Portlet does not render on page properly and errors are thrown in the browser console

       

       

      Attachments

        Issue Links

          Activity

            People

              sharry.shi Sharry Shi
              ivan.zaera Ivan Zaera
              Kiyoshi Lee Kiyoshi Lee
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                4 years, 5 weeks, 5 days ago

                Packages

                  Version Package
                  7.0.0 DXP FP58
                  7.0.0 DXP SP9
                  7.0.X