Details

    • Fix Priority:
      5

      Description

      Steps to repruduce:

      1. Update to latest 7.1.x.
      2. Try to build the bundle.

      Actual Result:
      BUILD FAILED.

           [exec] /opt/dev/projects/github/liferay-portal-7.1.x-private/modules/apps/portal/portal-monitoring/src/main/java/com/liferay/portal/monitoring/internal/portlet/MonitoringInvokerPortletFactoryImpl.java:45: error: method does not override or implement a method from a supertype
           [exec] 	@Override
           [exec] 	^
           [exec] /opt/dev/projects/github/liferay-portal-7.1.x-private/modules/apps/portal/portal-monitoring/src/main/java/com/liferay/portal/monitoring/internal/portlet/MonitoringInvokerPortletFactoryImpl.java:54: error: no suitable method found for create(com.liferay.portal.kernel.model.Portlet,javax.portlet.Portlet,PortletConfig,PortletContext,InvokerFilterContainer,boolean,boolean,boolean)
           [exec] 		InvokerPortlet invokerPortlet = _invokerPortletFactory.create(
           [exec] 		                                                      ^
           [exec]     method InvokerPortletFactory.create(com.liferay.portal.kernel.model.Portlet,javax.portlet.Portlet,PortletConfig,PortletContext,InvokerFilterContainer,boolean,boolean,boolean,boolean) is not applicable
           [exec]       (actual and formal argument lists differ in length)
           [exec]     method InvokerPortletFactory.create(com.liferay.portal.kernel.model.Portlet,javax.portlet.Portlet,PortletConfig,PortletContext,InvokerFilterContainer,boolean,boolean,boolean,boolean,boolean) is not applicable
           [exec]       (actual and formal argument lists differ in length)
           [exec]     method InvokerPortletFactory.create(com.liferay.portal.kernel.model.Portlet,javax.portlet.Portlet,PortletContext,InvokerFilterContainer) is not applicable
           [exec]       (actual and formal argument lists differ in length)
           [exec] Note: /opt/dev/projects/github/liferay-portal-7.1.x-private/modules/apps/portal/portal-monitoring/src/main/java/com/liferay/portal/monitoring/internal/messaging/MonitoringMessagingConfigurator.java uses or overrides a deprecated API.
           [exec] Note: Recompile with -Xlint:deprecation for details.
      

        Attachments

          Activity

            People

            • Assignee:
              support-lep@liferay.com SE Support
              Reporter:
              yvonne.han Yvonne Han
              Participants of an Issue:
              Recent user:
              Yvonne Han
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 2 weeks, 2 days ago

                Packages

                Version Package