Details

      Description

      DeprecatedModulesUpgradeTest failed caused by LPS-84138.

      The root reason is in LPS-84138, we stop using MultiVMPoolUtil and SingleVMPoolUtil which are using blocking version of ServiceProxyFactory to get an real service.

      After removing dependency on these two classes, some of the services might be initialized earlier before a real portal cache manager is initialized. For example, LayoutPersistenceImpl might be initialized by a dummy FinderCache.

      But this test DeprecatedModulesUpgradeTest depends on LayoutPersistenceImpl to clear local FinderCache, thus it failed randomly.

      The solution should be clear local cache explicitly

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              brian.chan Brian Chan
              Reporter:
              tina.tian Tina Tian
              Participants of an Issue:
              Recent user:
              Annie Wu (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 4 weeks, 2 days ago

                  Packages

                  Version Package
                  7.1.X
                  Master