Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-86798

Error message when configuring default language options in a site

    Details

      Description

      Once created, it is not possible to configure default language options for a Site if the Available Languages of the Instance have changed.

      Steps to reproduce:

      1. Start the portal with the default locales.
      2. Create a new Site called, for example, 'Test Site'.
      3. Choose 'Use the default language options' and click save.
      4. Go to Control Panel -> Configuration -> Instance Settings -> Miscellaneous and remove all current languages except for English (US) and Spanish (Spain).
      5. Configure Default Language to 'English (US)'.
      6. Click save.
      7. Go to Test Site -> Configuration -> Site Settings -> Languages.
      8. Select 'Use the default language options' radio button.
      9. Click save.

      Expected behaviour : the default language options are applied without any errors.

      Current behaviour : an error occurs and you are forced to select manually the configuration (see attached screeshots): if you click on the second option the specific error is shown.

      Note 1: it is also reproducible if in step 8 any change is applied to the site.

      Note 2: the validation of the languages is done against the site current languages ids, instead of the instance languages ids here

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  1 year, 1 week, 2 days ago

                  Packages

                  Version Package
                  7.0.0 DXP FP66
                  7.0.X
                  7.1.10 DXP FP5
                  7.1.10.1 SP1
                  7.1.2 CE GA3
                  7.1.X
                  Master