Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-87720

HTML Label for enabling auto tagging does not follow format of other checkboxes

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: Master
    • Fix Version/s: Master
    • Component/s: DM
    • Labels:

      Description

      When enabling auto tagging in
      Control Panel > Configuration > System Settings > Assets > Asset Auto Tagging
      the checkbox only states Enabled with a post script saying "Enable auto tagging of assets." For comparison, see checkboxes in
      Control Panel > Configuration > System Settings > Assets > Asset Publisher,
      where the checkbox label states what the checkbox is specifically for.

      This also affects the checkboxes in
      Control Panel > Configuration > Instance Settings > Asset Auto Tagging
      which ends up throwing browser errors for non-unique ID.

      Expected result: Instead of a post script, "Enable auto tagging of assets" could be used as the checkbox label instead"
      For reference, other checkboxes have the following labels:

      <label for="_com_liferay_portal_settings_web_portlet_PortalSettingsPortlet_ntlm_enabled">
      or
      <label for="_com_liferay_portal_settings_web_portlet_PortalSettingsPortlet_openid_enabled">
      

      Having the html consistent with other checkboxes help make the functional Poshi tests more stable.
      Thanks!

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  46 weeks, 4 days ago

                  Packages

                  Version Package
                  Master