Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-88190

Form field validation not working for element sets

    Details

      Description

      Steps to reproduce:

      1. Go to Content > Forms
      2. Add new element set
      3. Add a text field to the element set
      4. Set "required field" and "validation" to true and its condition to "is not email"
      5. Set an error message, like "email validation failed"
      6. Create a form with the element set
      7. Go to page and add a Form portlet
      8. Select the form
      9. Fill the form with a valid email address

      Expected result: Form will be saved
      Actual result: Form is not saved and error message is shown

      10. Go to Content > Forms and view entries for the form

      Expected result: there will be some entries, when the e-mail address was correct.
      Actual result: There are no form entries.

      The issue is not present when the text field is added to the form directly, not via element set.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  1 year, 11 weeks, 4 days ago

                  Packages

                  Version Package
                  7.1.10 DXP FP7
                  7.1.10.2 SP2
                  7.1.3 CE GA4
                  7.1.X
                  Master