Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-89026

index.on.startup=true fails after recent user indexer changes

    Details

    • Fix Priority:
      4
    • Sprint:
      Search | S02 Sprint 12, Search | S02 Sprint 13, Search | S02 Sprint 14, Search | S02 Sprint 15, Search | S02 Sprint 19

      Description

      Description
      Likely caused by this change to the users indexer https://github.com/brianchandotcom/liferay-portal/pull/66399
      When starting up Portal, the default user is not indexed properly, preventing that user from being edited, added to an organization, etc. Reindexing will fix the problem, so the issue is not super bad, although this is a problem for our automated functional tests

      Workaround
      Re-index Search

      Steps to Reproduce

      1. Set index.on.startup=true in portal-ext
      2. Start Liferay on Clean Bundle
      3. Navigate to Users & Organizations

      Expected Result
      Default User Available

      Actual Result
      Default User Missing

      Tested on Tomcat 9.0.10 + MySQL 5.7
      Portal master GIT ID: 995483490f9820d184844dfc853db9a8536f9f9a

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Days since last comment:
                  13 weeks, 3 days ago

                  Packages

                  Version Package