Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-90408

Some assets that are created in Widget are staged even if staging is not enabled for those assets

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 7.1.X
    • Fix Version/s: 7.1.X
    • Component/s: Staging
    • Labels:
    • Story Points:
      0.25
    • Fix Priority:
      4

      Description

      Steps to Reproduce:

      1. Add a site and a page.
      2. Enable local staging with default configurations (Blogs is not staged by default).
      3. Add Blogs Widget to the page.
      4. Publish to Live.
      5. Go to Site Administration > Content > Blogs.
      6. Add a new blog blog1.
      7. Assert that blog1 doesn't display in Blogs Widget of Staging site, but displays in Live site.
      8. Go to Staging site, add blog2 via Blogs Widget.
      9. Go to Live site, check the Blogs Widget.

      Expected Results:
      Blog2 should display in Live site immediately same as blog1.

      Actual Results:
      Blog1 displays in Live site, but doesn't display in Staging site, and in Staging site, there is no warning message in Blogs Widget.
      Blog2 doesn't display in Live site, only blog1 displays, need to click Publish to Live.

      Note:
      Same issue also affects Message Boards and Document Media.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  9 weeks, 4 days ago

                  Packages

                  Version Package
                  7.1.X