Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-90472

Comments imported into the staging site disappear when published to live

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: Master
    • Fix Version/s: None
    • Component/s: Comments, Staging
    • Labels:
      None

      Description

      Steps to reproduce:

      1. Add a comment to an asset (DM, Blogs, Wiki)
      2. Export asset (with comment)
      3. Start new instance of Portal and enable staging
      4. Import exported LAR into staging site (the one I used is attached)
      5. Navigate to staging site and add the relevant widget to display the asset
      6. Assert asset is displayed, has one comment, and that the comment is disabled
      7. Publish to live
      8. Navigate to live site

      Expected result:
      Asset should be published with comment to live.

      Actual result:
      Asset is published, but comment is not.

      Reproduced on:
      Tomcat 9.0.10 + MySQL 5.7.
      Portal master 924e5d41cad47f0e8732453573b67e6a3f824568

        Attachments

          Activity

            People

            Assignee:
            austin.chiang Austin Chiang
            Reporter:
            austin.chiang Austin Chiang
            Participants of an Issue:
            Recent user:
            Rubén Heras
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 9 weeks, 5 days ago

                Packages

                Version Package