Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-9055

First deploy of ext-plugin from vanilla SDK throws error because of missing dist/ folder

    Details

    • Branch Version/s:
      5.2.x, 5.1.x
    • Backported to Branch:
      Committed

      Description

      Testing newly build SDK from 20100415

      To reproduce:
      1. Build latest SDK
      2. Setup build.user.properties
      3. Create Ext plugin using create script
      4. Deploy blank Ext plugin project

      During the deployment you will see the following error:

      war:
      [zip] Note: creating empty zip archive E:\liferay\testing\sdk-20100415\ext\portal-ext\docroot\WEB-INF\ext-service\ext-service.jar

      war-util:
      [zip] Note: creating empty zip archive E:\liferay\testing\sdk-20100415\ext\portal-ext\docroot\WEB-INF\ext-util-bridges\ext-util-bridges.jar
      [copy] Copying 1 file to E:\liferay\testing\sdk-20100415\ext\portal-ext\docroot\WEB-INF\ext-impl\classes\com\liferay\portal\deploy\dependencies

      war-util:
      [zip] Note: creating empty zip archive E:\liferay\testing\sdk-20100415\ext\portal-ext\docroot\WEB-INF\ext-util-java\ext-util-java.jar
      [copy] Copying 1 file to E:\liferay\testing\sdk-20100415\ext\portal-ext\docroot\WEB-INF\ext-impl\classes\com\liferay\portal\deploy\dependencies

      war-util:
      [zip] Note: creating empty zip archive E:\liferay\testing\sdk-20100415\ext\portal-ext\docroot\WEB-INF\ext-util-taglib\ext-util-taglib.jar
      [copy] Copying 1 file to E:\liferay\testing\sdk-20100415\ext\portal-ext\docroot\WEB-INF\ext-impl\classes\com\liferay\portal\deploy\dependencies
      [zip] Building zip: E:\liferay\testing\sdk-20100415\ext\portal-ext\docroot\WEB-INF\ext-impl\ext-impl.jar
      [zip] Building zip: E:\liferay\testing\sdk-20100415\dist\portal-ext-6.0.0.1.war

      BUILD FAILED
      E:\liferay\testing\sdk-20100415\ext\build-common-ext.xml:246: Problem creating zip: E:\liferay\testing\sdk-20100415\dist\portal-ext-6.0.0.1.war (The system cannot find the path specified) (and the archive is probably corrupt but I could not delete it)

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              gregory.amerson Gregory Amerson
              Reporter:
              gregory.amerson Gregory Amerson
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                10 years, 34 weeks, 3 days ago

                  Packages

                  Version Package
                  6.0.1 RC