Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-90792

[New Form Builder] "User Belongs To" rule is not working in user view

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: Master
    • Fix Version/s: Master
    • Component/s: Forms
    • Labels:

      Description

      Summary:

      "User Belongs To" rule is not working in user view

      Steps to reproduce:

      1. Go to System Settings > Forms > Enable the experimental interface;
      2. Add the Site Administrator permission to the user Test (Control Panel > Users > Users and Organizations > select the user Test > Roles > Site Roles > Select Site Administrator > Save)
      3. Go to Content > Forms;
      4. Click to add a New Form;
      5. Add two Text Fields <Manager> and <Public>;
      6. Go to Rules and add the following rule: If the User Belongs To Site Administrator Show <Manager> AND Require <Manager>;
      7. Publish the Form;
      8. Open the URL and see that only the field <Public> is shown;
      9. Add this Form in a Portlet Page and notice that only the field <Public> is shown;

      Expected result:

      Since the user is set to Site Administrator, the "User Belongs To" form rule should work properly and show only the field <Manager>.

      Actual result:

      The "User Belongs To" is not working and is showing the not expected field <Public>.

      Reproducible On:

      4dda6fa7afb54feef301333920a523f214b8e05c

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                31 weeks, 2 days ago

                Packages

                Version Package
                Master