Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-91089

Unable to add multiple tags to asset using comma key

    Description

    Steps to reproduce:

    1. Navigate to Content > Blogs and create or edit a blog
    2. Populate the Blog Title and Blog Content fields
    3. Expand the Categorization panel
    4. Type "first" into the tag input field
    5. Hit the comma key, i.e. ","
    6. Type "second" into the tag input field
    7. Hit the comma key
    8. Type "third" into the tag input field
    9. Hit the comma key
    10. Click Publish

    Expected result: The blog is published with all three tags saved

    Actual result: The blog fails to publish and following error message appears: "One or more tags contains invalid characters.". Also, all tags except the first are removed from the tags input field.

    Note: This happens on other asset edit forms as well including Web Content. Using commas to enter tags should work according to https://lexicondesign.io/docs/patterns/Forms/selector.html
    However, an easy workaround is to user the Enter key instead.

    Reproduced on:
    Tomcat 9.0.10 + MySQL 5.7.25
    Portal master Git SHA 19c298f369f37573a64390af386055d11d2638e6

      Attachments

        Issue Links

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                35 weeks ago

                Packages

                Version Package