Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-91472

Non-English installation, content creation broken due to required fields in en_US

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Duplicate
    • Affects Version/s: 7.2.0 Alpha 1, Master
    • Fix Version/s: Master
    • Component/s: WCM
    • Labels:
    • Fix Priority:
      3
    • JDK:
      Oracle Sun JDK 5

      Description

      When choosing German as portal language in the setup wizard, the installation sets German as default language. But English is still a required language for content. An English translation has to be added always.

      Steps to reproduce:

      1) In setup wizard, choose German

      2) Create a webcontent

      3) Enter a title (Note the German flag/de-DE for the field)

      Click Publish/Publizieren.

      Expected result: Content is published.

      Actual result: Error: Bitte geben Sie einen gültigen Titel an. 

      English is indeed the problem, to confirm: Click the de-DE Icon, switch to en-US and enter some text.  The content can be saved.

      I checked the usual suspects, instance settings and site settings, but everything looks fine.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  40 weeks, 1 day ago

                  Packages

                  Version Package
                  Master