Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-92079

Can create a site called "." that doesn't work

    Details

      Description

      Steps to reproduce:

      1. Go to Control Panel > Sites > Sites
      2. Add a site
      3. Name site "." or ".."

      Expected result:

      Site with period characters cannot be created

      Actual result:

      Site cannot be found for "." and when ".." is created there is an Http Status 404 - Not Found error and a warning in the console log

       2019-03-13 23:26:54.662 WARN  [http-nio-8080-exec-8][code_jsp:172] {code="404", msg="/~/control_panel/manage/-/site/settings", uri=/~/control_panel/manage/-/site/settings}
      

      Reproduced on:

      Tomcat 9.0.10 + MySQL 5.7.

      Portal Master GIT Commit: 781476802d5bd4435f4fbb49cf1f73b1e9b95398

        Attachments

          Activity

            People

            Assignee:
            brooke.dalton Brooke Dalton
            Reporter:
            brooke.dalton Brooke Dalton
            Participants of an Issue:
            Recent user:
            Brooke Dalton
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              2 years, 37 weeks, 2 days ago

                Packages

                Version Package
                Master