Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-9314

unable to deploy liferay 6.0.1 on websphere 7.0.0.9

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.0.1 RC
    • Fix Version/s: 6.0.4 GA
    • Labels:
      None
    • Environment:
      liferay-6.0.1.war , websphere 7.0.0.9 , linux, windows 7

      Description

      when trying to deploy liferay-6.0.1.war in websphere console, an error appears:

      "The EAR file could be corrupt and/or incomplete. Make sure that
      the application is at a compatible Java(TM) Platform, Enterprise
      Edition (Java EE) level for the current version of WebSphere(R)
      Application Server."

      the cause is probably the file "WEB-INF/ibm-web-bnd.xmi".

      see
      http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg1PK78515
      "..Explanation:
      xmi format bindings files are not supported for EE5 modules. Use
      xml format instead."

      anyway, it was not a problem to deploy liferay-6.0.0.war on websphere 7.0.0.7 (win) with the same "WEB-INF/ibm-web-bnd.xmi"

      deployment is possible after deleting the xmi file.
      (not sure if there are any side effects)

        Attachments

        1. ibm-web-bnd.xml
          0.3 kB
        2. ibm-web-ext.xml
          0.5 kB

          Issue Links

            Activity

              People

              Assignee:
              mark.jin Mark Jin (Inactive)
              Reporter:
              daniel.weisse Daniel Weisse (Inactive)
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                10 years, 36 weeks, 1 day ago

                  Packages

                  Version Package
                  6.0.4 GA