Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-93425

New friendly URLs do not link properly to their assets and lead to "Not found" pages

    Details

      Description

      Reproduced on:
      Tomcat 9.0.10 + MySQL 5.7. Portal master GIT ID: 8cfef1331a532221c9b0bbeac98cf8d49495f3ce.

      This is almost exactly the same issue as LPS-93320 (which was closed earlier today, so this issue is very recent).

      Steps to reproduce:

      1. Add a display page template
      2. Add a web content article that uses the display page template
      3. View the web content article either through Web Content Admin kebab > view/preview or through asset publisher

      Expected result:
      User is able to view web content through the display page.

      Actual result:
      User is taken to a not found page.

      New url (doesn't work):

      http://localhost:8080/web/guest/wc/${article-title}

      If the user uses the old friendly url, it will work.

      http://localhost:8080/web/guest/-/${article-title}

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                brian.chiu Brian Chiu (Inactive)
                Reporter:
                brian.chiu Brian Chiu (Inactive)
                Participants of an Issue:
                Recent user:
                Kimberly Chau
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  32 weeks ago

                  Packages

                  Version Package
                  Master