Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-93811

Configure yarn to ensure usage of correct version of node within liferay-portal

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      We can set up a top-level .yarnrc file in portal that points at a wrapper that makes sure you use the portal version of node when running yarn commands. This will prevent people from breaking their modules by compiling packages that have native components with the wrong version of Node (example: node-sass, which is used in themes).

        Attachments

          Activity

            People

            • Assignee:
              greg.hurrell Greg Hurrell
              Reporter:
              greg.hurrell Greg Hurrell
              Recent user:
              Greg Hurrell
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Packages

                Version Package