Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-9485

Liferay stops logging on JBOSS 5.1 to server.log

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Duplicate
    • Affects Version/s: 6.0.2 RC
    • Fix Version/s: 6.0.4 GA
    • Labels:
      None
    • Environment:
      Windows XP, Windows 2003
      JBOSS 5.1
      liferay-portal-jboss-6.0.1.zip
      Java 1.6.0_18

      Description

      The last log line before it stops logging is:
      2010-05-07 13:16:47,316 INFO [org.jboss.web.tomcat.service.deployers.TomcatDeployment] (main) deploy, ctxPath=/

      Log4j is logging the server startup up to a certain point in the server.log and then it stops (I've run server as both a console app or windows service). This does not happen when it logs to the console we get a full log in the console window all the way to the server startup.

      I have looked at liferay-portal-6.0.1\jboss-5.1.0\server\default\conf\jboss-log4j.xml
      The Console Appender and File Appender should be behaving in the same manner according to the configuration.
      I've even tried setting:

      <priority value="${jboss.server.log.threshold}"/>

      to:

      <priority value="INFO"/>

      A standalone JBoss 5.1 server on the same machines logs all the way to a server startup, so I assume this is an issue with you modifications to the standard JBoss 5.1 server.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  9 years, 20 weeks ago

                  Packages

                  Version Package
                  6.0.4 GA