Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-97326

Search not working correctly in Japanese

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 7.0.X, 7.1.10 DXP FP12, 7.1.X, 7.2.10 DXP GA1, 7.2.X, Master
    • Fix Version/s: None
    • Component/s: Search Infrastructure
    • Story Points:
      0.25
    • Fix Priority:
      3

      Description

      Steps to reproduce:

      1. Start liferay 7.2.x private
      2. Set site language to Japanese
      3. Create 2 web content with following content: 東京 and 京都
      4. Search for 東 (only 東京 should be displayed)
      5. Search for 東京

      Expected result:

      Only one web content displays, 東京

      Actual result:

      Both contents, 東京 and 京都, are displayed as if it's not using the Japanese tokenizer/analyzer

       

      Reproduced on:

      Tomcat 9.0.17 + MySQL 5.7.

      Portal 7.2.x Private GIT Commit: 739c6224979775ecf111197969f62ded7ca4e17b

        Attachments

          Activity

            People

            • Assignee:
              support-lep@liferay.com SE Support
              Reporter:
              brooke.dalton Brooke Dalton
              Participants of an Issue:
              Recent user:
              Brian Suh
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                16 weeks, 1 day ago

                Packages

                Version Package