Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-97772

IE11 AlloyEditor toolbar automatically appears after adding an image

    Details

    • Type: Bug
    • Status: Verified
    • Resolution: Unresolved
    • Affects Version/s: 7.0.X, 7.1.X, 7.2.X, Master
    • Fix Version/s: None
    • Component/s: Alloy Editor
    • Labels:
      None
    • Fix Priority:
      3

      Description

      Background:
      This is a copy of LPS-94904.

      The proper behavior is adding a new line after adding an image as per LPS-83248. Because of the new line the toolbar
      should not appear automatically – it should only appear on manual selection of the image. IE11 passes LPS-83248 adding the new line, however the toolbar still pops up and this leads to errors like LPS-90148 (as the toolbar isn't 'attached' to selections).

      I'm reproducing on IE11 Version 11.437.17763.0 (Update Version 11.0.1.120)

      Steps to Reproduce:
      1. On IE11 add a new Web Content Display to a page
      2. Create a new Basic Web Content
      3. Insert an image into the content

      Expected Result:
      The toolbar does not automatically appear after adding an image. IE11 behavior is the same as other browsers.

      Actual Result:
      The toolbar appears automatically after adding an image. IE11 is unique in showing the toolbar.

      Reproduced
      Master: 93b3c4d1dcb14e35454da8cca5985d4137f3c16c
      7.1.x: ccebef7ba4bf109dbd94688ac5026751e6c6eb4f
      7.0.x: d7f15505a693b41bcb8cff5ab2aeb8dba15c5cc0

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Days since last comment:
                  1 week, 4 days ago

                  Packages

                  Version Package