Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-98018

IE11 - Alloy Editor is not setting nor reading the alt text attribute on images, alt text is being wiped out

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 7.0.0 DXP FP83, 7.0.X, 7.1.X, 7.2.X, Master
    • Fix Version/s: Master
    • Component/s: Alloy Editor
    • Labels:

      Description

      Found in DE-83 with IE11. Image alt text written in Chrome is not being read in IE11. Additionally content edited in IE only and never any other browser, always fails to save typed alt text. There are some instances also where Anti Sammy maybe stripping the alt text, plus the icon fails to stay lit when entering alt text.

      In summary

      • Alt text typed into chrome fails to show in the alt text bar of alloy editor in IE11
      • Alt text typed in IE11 only fails to save
      • Both browsers suffer from an unlit alt icon in the black image bar of Alloy Editor
      • Both browsers suffer from loss of alt text possibly because of anti sammy.

        Attachments

        1. Chrome.png
          Chrome.png
          229 kB
        2. IE alt text bar.png
          IE alt text bar.png
          163 kB
        3. IE HTML.png
          IE HTML.png
          196 kB

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                5 weeks, 2 days ago

                Packages

                Version Package
                Master