Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-98309

Could not resolve module com.liferay.portal.search.elasticsearch6.impl

    Details

    • Branch Version/s:
      7.2.x

      Description

      Stacktrace:

          [junit] 06:47:49,386 ERROR [Framework Event Dispatcher: Equinox Container: 56f093aa-5c6a-4a0f-b3a8-fb4b61694cf4][Framework:93] FrameworkEvent ERROR 
          [junit] org.osgi.framework.BundleException: Could not resolve module: com.liferay.portal.search.elasticsearch6.impl [160]
          [junit]   Unresolved requirement: Import-Package: com.liferay.portal.search.engine.adapter.search; version="[3.2.0,3.3.0)"
          [junit] 
          [junit] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
          [junit] 06:47:49,388 ERROR [Framework Event Dispatcher: Equinox Container: 56f093aa-5c6a-4a0f-b3a8-fb4b61694cf4][Framework:108] Exiting the JVM 
          [junit] org.osgi.framework.BundleException: Could not resolve module: com.liferay.portal.search.elasticsearch6.impl [160]
          [junit]   Unresolved requirement: Import-Package: com.liferay.portal.search.engine.adapter.search; version="[3.2.0,3.3.0)"
          [junit] 
          [junit] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
          [junit] Tests run: 2, Failures: 2, Errors: 0, Skipped: 0, Time elapsed: 0.415 sec
          [junit] Tests run: 2, Failures: 2, Errors: 0, Skipped: 0, Time elapsed: 0.415 sec
          [junit] 
          [junit] Testcase: testScanXMLLog(com.liferay.portal.log.assertor.PortalLogAssertorTest):	FAILED
          [junit] 
          [junit] Portal log assert failure, see above log for more information: 
          [junit] FrameworkEvent ERROR 
          [junit] org.osgi.framework.BundleException: Could not resolve module: com.liferay.portal.search.elasticsearch6.impl [160]
          [junit]   Unresolved requirement: Import-Package: com.liferay.portal.search.engine.adapter.search; version="[3.2.0,3.3.0)"
          [junit] 
          [junit] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
          [junit] 
          [junit] junit.framework.AssertionFailedError: 
          [junit] FrameworkEvent ERROR 
          [junit] org.osgi.framework.BundleException: Could not resolve module: com.liferay.portal.search.elasticsearch6.impl [160]
          [junit]   Unresolved requirement: Import-Package: com.liferay.portal.search.engine.adapter.search; version="[3.2.0,3.3.0)"
          [junit] 
          [junit] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
          [junit] 
          [junit] 	at com.liferay.portal.log.assertor.PortalLogAssertorTest.scanXMLLogFile(PortalLogAssertorTest.java:172)
          [junit] 	at com.liferay.portal.log.assertor.PortalLogAssertorTest$1.visitFile(PortalLogAssertorTest.java:98)
          [junit] 	at com.liferay.portal.log.assertor.PortalLogAssertorTest$1.visitFile(PortalLogAssertorTest.java:88)
          [junit] 	at java.nio.file.Files.walkFileTree(Files.java:2670)
          [junit] 	at java.nio.file.Files.walkFileTree(Files.java:2742)
          [junit] 	at com.liferay.portal.log.assertor.PortalLogAssertorTest.testScanXMLLog(PortalLogAssertorTest.java:86)
          [junit] 
          [junit] 
          [junit] Testcase: testScanOSGiLog(com.liferay.portal.log.assertor.PortalLogAssertorTest):	FAILED
          [junit] 
          [junit] Portal log assert failure, OSGi log found: /opt/dev/projects/github/liferay-portal-7.2.x/bundles/osgi/state/1563259650150.log:
          [junit] !SESSION 2019-07-16 06:47:49.384 -----------------------------------------------
          [junit] eclipse.buildId=unknown
          [junit] java.version=1.8.0_121
          [junit] java.vendor=Oracle Corporation
          [junit] BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
          [junit] 
          [junit] !ENTRY com.liferay.portal.search.elasticsearch6.impl 4 0 2019-07-16 06:47:49.384
          [junit] !MESSAGE FrameworkEvent ERROR
          [junit] !STACK 0
          [junit] org.osgi.framework.BundleException: Could not resolve module: com.liferay.portal.search.elasticsearch6.impl [160]
          [junit]   Unresolved requirement: Import-Package: com.liferay.portal.search.engine.adapter.search; version="[3.2.0,3.3.0)"
          [junit] 
          [junit] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
          [junit] 
          [junit] 
          [junit] junit.framework.AssertionFailedError: 
          [junit] Portal log assert failure, OSGi log found: /opt/dev/projects/github/liferay-portal-7.2.x/bundles/osgi/state/1563259650150.log:
          [junit] !SESSION 2019-07-16 06:47:49.384 -----------------------------------------------
          [junit] eclipse.buildId=unknown
          [junit] java.version=1.8.0_121
          [junit] java.vendor=Oracle Corporation
          [junit] BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
          [junit] 
          [junit] !ENTRY com.liferay.portal.search.elasticsearch6.impl 4 0 2019-07-16 06:47:49.384
          [junit] !MESSAGE FrameworkEvent ERROR
          [junit] !STACK 0
          [junit] org.osgi.framework.BundleException: Could not resolve module: com.liferay.portal.search.elasticsearch6.impl [160]
          [junit]   Unresolved requirement: Import-Package: com.liferay.portal.search.engine.adapter.search; version="[3.2.0,3.3.0)"
          [junit] 
          [junit] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
          [junit] 
          [junit] 
          [junit] 	at com.liferay.portal.log.assertor.PortalLogAssertorTest.testScanOSGiLog(PortalLogAssertorTest.java:81)
          [junit] 
          [junit] 
          [junit] Test com.liferay.portal.log.assertor.PortalLogAssertorTest FAILED
      

        Attachments

          Activity

            People

            • Assignee:
              brian.lee Brian Lee
              Reporter:
              joshua.itagaki Joshua Itagaki
              Participants of an Issue:
              Recent user:
              Jason Pince
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 3 weeks, 4 days ago

                Packages

                Version Package
                7.2.X
                7.2.1 CE GA2