Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Completed
    • Affects Version/s: None
    • Fix Version/s: 7.0.X, 7.1.X, 7.2.X
    • Component/s: Legacy Components
    • Labels:
      None

      Description

      Causing startup error

      org.osgi.framework.BundleException: Could not resolve module: com.liferay.lcs.client.api [322]
      Unresolved requirement: Import-Package: com.liferay.portal.kernel.exception; version="[7.0.0,9.0.0)"
      

      Version defined in LCS code on 7.0.x-private (https://github.com/liferay/liferay-portal-ee/blob/fc27926ee063abebc997b11120424ec2180f72e0/modules/private/apps/lcs/lcs-client-api/bnd.bnd#L18), and this will continue to break as we bump this version like we did in LPS-97975 on master.

        Attachments

          Activity

            People

            Assignee:
            victor.ware Victor Ware
            Reporter:
            victor.ware Victor Ware
            Engineering Assignee:
            Victor Ware
            Recent user:
            Enterprise Release HU
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Packages

                Version Package
                7.0.X
                7.1.X
                7.2.X