Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-99898

Enforce use of exact versions to specify dependencies on packages provided by frontend-js-react-web

    Details

    • Branch Version/s:
      7.2.x, 7.1.x, 7.0.x
    • Backported to Branch:
      Committed
    • Sprint:
      S03E08- Seoul

      Description

      For example:

      segments-web should depend on react-dnd 7.7.0 (not "^7.7.0") because frontend-js-react-web provides 7.7.0.

      (likewise for all the other dependencies provided by frontend-js-react-web).

      Should be something we can enforce via the source formatter.

        Attachments

          Activity

            People

            Assignee:
            jose.balsas Chema Balsas
            Reporter:
            greg.hurrell Greg Hurrell
            Engineering Assignee:
            SE Support
            Recent user:
            Clarissa Velazquez
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Packages

                Version Package
                7.0.X
                7.1.10 DXP FP14
                7.1.10.3 SP3
                7.1.X
                7.2.10 DXP FP2
                7.2.10.1 DXP SP1
                7.2.X