Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.0.1 RC
    • Fix Version/s: --Sprint 12/11, 6.1.0 CE RC1
    • Component/s: UI Infrastructure
    • Labels:
      None
    • Environment:
      Trunk + MySQL Firefox 3.6.4 Reversion:54321.
    • Similar Issues:
      Show 4 results 

      Description

      Start liferay bundle.
      Click "Create Account" button.
      You can not find verification code.
      Then tomcat get following error,

      Error message:
      06:11:28,240 ERROR [IncludeTag:229] Current URL /web/guest/home?p_auth=vjLNiJ45&p_p_id=58&p_p_lifecycle=1&p_p_state=maximized&p_p_mode=view&p_p_col_id=column-1&p_p_col_co
      unt=1&saveLastPath=0&_58_struts_action=%2Flogin%2Fcreate_account generates exception: java.lang.NullPointerException
      06:11:28,257 ERROR [IncludeTag:156] java.lang.NullPointerException
      at com.liferay.portal.kernel.captcha.CaptchaUtil.getTaglibPath(CaptchaUtil.java:49)
      at org.apache.jsp.html.taglib.ui.captcha.page_jsp._jspService(page_jsp.java:861)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374)
      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)
      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:630)
      at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:535)
      at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:472)
      at com.liferay.taglib.util.IncludeTag.include(IncludeTag.java:177)
      at com.liferay.taglib.util.IncludeTag._doInclude(IncludeTag.java:221)
      at com.liferay.taglib.util.IncludeTag.doEndTag(IncludeTag.java:60)
      at org.apache.jsp.html.portlet.login.create_005faccount_jsp._jspService(create_005faccount_jsp.java:2116)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374)

        Issue Links

          Activity

          Zsolt Szabo added a comment -

          This works properly on Trunk (Revision:54455)

          Michael Saechang added a comment -

          Confirmed that it is working on revision 54489. Issue is now fixed.

          Vicki Tsang added a comment -

          This is being bulk edited to prepare for new workflow


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 16 weeks, 5 days ago

                Development

                  Structure Helper Panel