Uploaded image for project: 'PUBLIC - Liferay Documentation'
  1. PUBLIC - Liferay Documentation
  2. LRDOCS-5752

Update Article: Theme Builder Gradle Plugin

    Details

      Description

      The documentation for Theme Builder Gradle Plugin needs to be updated. Specifically, the Parent Theme Dependencies section of the article.

      Here is the dev.liferay link: https://dev.liferay.com/en/develop/reference/-/knowledge_base/7-0/theme-builder-gradle-plugin#parent-theme-dependencies 

      The section currently states that:

      By default, the plugin creates a configuration called parentThemes and adds dependencies to the latest released versions of the Liferay Frontend Theme Styled, Liferay Frontend Theme Unstyled, and Liferay Frontend Theme Classic artifacts. It is possible to override this setting and use a specific version of the artifacts by manually adding dependencies to the parentThemes configuration.
      

      In the above excerpt, we state that customers/developers could use a specific version of the artifacts by manually adding dependencies to the parentThemes configuration.

      The following is shown as an example of how customers/developers could override the setting:

      dependencies {
          parentThemes group: "com.liferay", name: "com.liferay.frontend.theme.styled", version: "2.0.13"
          parentThemes group: "com.liferay", name: "com.liferay.frontend.theme.unstyled", version: "2.0.13"
          parentThemes group: "com.liferay.plugins", name: "classic-theme", version: "1.0.29"
      }

      There are two things that need to be added to this section.

      1. Make it clear to customers and developers that the dependency excerpt is an example and does not apply to all DXP environments. (For example, DE-50 environment requires the version of classic-theme to be 1.0.49.)
      2. Either describe how developers could find what version their dependencies need to be directly in the article or provide a link to an article that explains how developers can check to ensure their dependencies have the correct version.

      For any questions seeking clarification, please reach out to Brian I. Kim as he initiated this request.

      Thanks!

        Attachments

          Activity

            People

            Assignee:
            richard.sezov Rich Sezov
            Reporter:
            paul.genua Paul Genua (Inactive)
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support

                  Packages

                  Version Package
                  7.0.x
                  7.1.x