Uploaded image for project: 'PUBLIC - Liferay Documentation'
  1. PUBLIC - Liferay Documentation
  2. LRDOCS-7765

Is not possible to use a minor version on a module in Liferay Workspace

    Details

    • Type of Documentation:
      Developer

      Description

      Once the client upgrades to workspace version "2.2.2" or higher, in order to override a third-party library he needs to be using "force: true" in their module "build.gradle".

      This change was introduced when we upgraded to use Gradle 5 in the workspace. Here's a changelog of differences between Gradle 4.10.2 (Workspace 2.2.1) and 5.6.4(Workspace => 2.2.2). Also, we started publishing our own changelog for workspace. 

      Example using 'force: true':

      compileOnly group: "org.apache.poi", name: "poi", version: "3.9", force: true

      Before this version, this wasn't needed.

      We need to update the documentation regarding this change.

      For more details follow up this Jira https://issues.liferay.com/browse/PTR-1605

      Here is the Jira related to the change https://issues.liferay.com/browse/LPS-105889

      Outdated documentation: https://help.liferay.com/hc/en-us/articles/360017885412-Updating-Liferay-Workspace-

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              richard.sezov Rich Sezov
              Reporter:
              georgel.pop Georgel Vasile Pop
              Participants of an Issue:
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:

                  Zendesk Support

                    Packages

                    Version Package
                    7.0.x
                    7.1.x
                    7.2.x
                    7.3.x