Uploaded image for project: 'PUBLIC - Liferay Documentation'
  1. PUBLIC - Liferay Documentation
  2. LRDOCS-8769

Installing v6.6.0 will lead to an error

Details

    • Bug
    • Status: Documentation Prioritized
    • Minor
    • Resolution: Unresolved
    • 7.0.x
    • Product Team Dev Tools
    • None
    • Developer

    Description

      Flagged by alfonso.crisci

      Article Link: https://help.liferay.com/hc/en-us/articles/360018162071#installing-the-theme-generator

      The Liferay Theme Generator has several dependencies. Follow these steps to install them:

      1. Install Node.js, if it's not already installed. We recommend installing v6.6.0, which is the version Liferay Portal 7.0 supports.

      Comment: Installing v6.6.0 will lead to an error like the one reported at https://liferay-support.zendesk.com/agent/tickets/33072.

      Please see the reproduction steps here: https://liferay-support.zendesk.com/agent/tickets/33072?comment=1234790139332

      The issue is solved with the latest node version v12, or with lower ones as well, although I couldn't fully test what is the first good working version.

      Could the recommendation regarding installing Node v6.6.0 be reviewed? Thanks!"

      Attachments

        Activity

          People

            alec.shay Alec Shay
            jay.lee Jay Lee
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:

              Packages

                Version Package
                7.0.x