Uploaded image for project: 'PUBLIC - Liferay Maven'
  1. PUBLIC - Liferay Maven
  2. MAVEN-209

liferay-maven-plugin:6.2.5:build-css effective pom model too restrictive, build fails

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 6.2.0 GA1
    • Fix Version/s: None
    • Component/s: Plugins
    • Labels:
      None
    • Environment:
      Maven-3.3.9
      liferay-maven-plugin:6.2.5

      Description

      The lifray-maven-plugin lets a plugin's project build fail due to too restrictive pom validation:

      For example "'distributionManagement.status' must not be specified"
      or "'build.plugins.plugin.version' for org.apache.maven.plugins:maven-surefire-plugin is missing".

      Steps to reproduce:

      • Unzip sample-maven-portlet.zip,
      • Import as existing maven project in Eclipse
      • Quickly edit pom.xml to customize the properties section to your needs
      • Run mvn clean package -> build fails
      • Uncomment dependency commons-configuration -> build succeeds.

      Critical output:
      [INFO] ------------------------------------------------------------------------
      [INFO] Building sample-maven-portlet Portlet 0.0.1-SNAPSHOT
      [INFO] ------------------------------------------------------------------------
      [INFO]
      [INFO] — liferay-maven-plugin:6.2.5:build-css (default) @ sample-maven-portlet —
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 1.664 s
      [INFO] Finished at: 2016-03-21T17:16:51+01:00
      [INFO] Final Memory: 12M/219M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal com.liferay.maven.plugins:liferay-maven-plugin:6.2.5:build-css (default) on project sample-maven-portlet: Some problems were encountered while processing the POMs:
      [ERROR] [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-surefire-plugin is missing. @ line 196, column 15
      [ERROR] [ERROR] 'distributionManagement.status' must not be specified. @ line 417, column 13: 2 problems were encountered while building the effective model for commons-configuration:commons-configuration:1.6
      [ERROR] [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-surefire-plugin is missing. @ line 196, column 15
      [ERROR] [ERROR] 'distributionManagement.status' must not be specified. @ line 417, column 13
      [ERROR] -> [Help 1]

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 34 weeks, 1 day ago

                Packages

                Version Package