Uploaded image for project: 'PUBLIC - Liferay Social Office Community Edition'
  1. PUBLIC - Liferay Social Office Community Edition
  2. SOS-1781

Join functionality is not working in Site portlet when user is Logged out

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Won't Fix
    • Affects Version/s: 2.0.5 EE
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      LIFERAY VERSION: 6.1 GA2
      SOCIAL OFFICE VERSION: 2.0.5
      OPERATING SYSTEM: Other Linux Distribution
      APPLICATION SERVER: Tomcat 7.0
      JAVA VIRTUAL MACHINE: N/A
      DATABASE: SQL Server 2008 R2

      Description

      Steps to replicate the issue:

      1) Install and integrate Liferay and Social Office.
      2) Login with admin privileges.
      3) Go to Control panel-> Social Office Configurations -> add admin user to have social access.
      4) Add sites portlet to the public page.
      5) By default Liferay will be listed.
      6) Perform Logout action.
      7) Click Site Directory under Sites portlet.
      8) Click Join icon under Liferay site.
      9) No action performed and neither the icon is changed.
      --------------------------------------------------------------------
      Note: When the user logged in the functionality is working fine any user can join and leave under the Sites Directory option.

      Find screen shot after clicking join and no action performed

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                5 years, 38 weeks, 1 day ago

                Packages

                Version Package