PUBLIC - Liferay Social Office Community Edition
  1. PUBLIC - Liferay Social Office Community Edition
  2. SOS-1867

Landing on a site with the bookmarks portlet deployed results in console errors and empty portlet

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.X CE, 2.1.X EE
    • Fix Version/s: 3.0 EE GA1, 3.0 CE GA1
    • Labels:
      None
    • Environment:
      Tomcat 7 + MySQL 5. Portal 6.2.X CE Git ID: c152ece7cec890d044adb0a789f39f821d14af54.
      Plugins 6.2.X CE Git ID: 232cfdba2205cc599f83cbf449bfa6aaa7891666.
    • Fix Priority:
      5
    • Affects Portal Version/s:
      6.2.x
    • Similar Issues:
      Show 5 results 

      Description

      Landing on a site with the bookmarks portlet deployed results in console errors and empty portlet.

      1. Create a new SO site.
      2. Navigate to the site.

      Actual result: The console will give you errors and the bookmarks portlet is blank.

      Expected result: There should be no console errors and the bookmarks portlet should be functional.

      22:34:49,491 INFO  [localhost-startStop-3][HookHotDeployListener:814] Hook for so-hook is available for use
      Oct 30, 2013 10:43:02 PM org.apache.catalina.core.ApplicationDispatcher invoke
      SEVERE: Servlet.service() for servlet jsp threw exception
      org.apache.jasper.JasperException: Unable to compile class for JSP:
      
      An error occurred at line: 27 in the jsp file: /html/portlet/bookmarks/view.so-hook.jsp
      preferences cannot be resolved
      24:
      25: BookmarksFolder folder = (BookmarksFolder)request.getAttribute(WebKeys.BOOKMARKS_FOLDER);
      26:
      27: long defaultFolderId = GetterUtil.getLong(preferences.getValue("rootFolderId", StringPool.BLANK), BookmarksFolderConstants.DEFAULT_PARENT_FOLDER_ID);
      28:
      29: long folderId = BeanParamUtil.getLong(folder, request, "folderId", defaultFolderId);
      30:
      
      
      An error occurred at line: 76 in the jsp file: /html/portlet/bookmarks/view.so-hook.jsp
      The method getEntriesOrderByComparator(String, String) is undefined for the type BookmarksUtil
      73: >
      74:
      75:     <%
      76:     OrderByComparator orderByComparator = BookmarksUtil.getEntriesOrderByComparator("name", "asc");
      77:     %>
      78:
      79:     <liferay-ui:search-container-results
      
      
      Stacktrace:
              at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:103)
              at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:366)
              at org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:468)
              at org.apache.jasper.compiler.Compiler.compile(Compiler.java:378)
              at org.apache.jasper.compiler.Compiler.compile(Compiler.java:353)
              at org.apache.jasper.compiler.Compiler.compile(Compiler.java:340)
              at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:646)
              at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:357)
              at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
              at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
              at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:116)
              at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilter.doFilter(InvokerFilter.java:96)
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
              at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:749)
              at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:605)
              at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:544)
              at com.liferay.portal.servlet.DirectServletPathRegisterDispatcher.include(DirectServletPathRegisterDispatcher.java:55)
              at com.liferay.portal.servlet.ClassLoaderRequestDispatcherWrapper.doDispatch(ClassLoaderRequestDispatcherWrapper.java:78)
              at com.liferay.portal.servlet.ClassLoaderRequestDispatcherWrapper.include(ClassLoaderRequestDispatcherWrapper.java:53)
              at com.liferay.taglib.util.IncludeTag.include(IncludeTag.java:295)
              at com.liferay.taglib.util.IncludeTag.doInclude(IncludeTag.java:192)
              at com.liferay.taglib.util.IncludeTag.doEndTag(IncludeTag.java:83)
              at org.apache.jsp.html.common.themes.portlet_jsp._jspService(portlet_jsp.java:3807)
              at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
              at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:432)
              at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
              at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
              at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:116)
              at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilter.doFilter(InvokerFilter.java:96)
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
              at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:749)
              at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:605)
              at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:544)
              at com.liferay.portlet.PortletRequestDispatcherImpl.dispatch(PortletRequestDispatcherImpl.java:331)
              at com.liferay.portlet.PortletRequestDispatcherImpl.include(PortletRequestDispatcherImpl.java:128)
              at com.liferay.portal.struts.PortletRequestProcessor.doInclude(PortletRequestProcessor.java:370)
              at com.liferay.portal.struts.PortletRequestProcessor.doForward(PortletRequestProcessor.java:338)
              at org.apache.struts.tiles.TilesRequestProcessor.processTilesDefinition(TilesRequestProcessor.java:239)
              at org.apache.struts.tiles.TilesRequestProcessor.processForwardConfig(TilesRequestProcessor.java:302)
              at com.liferay.portal.struts.PortletRequestProcessor.processForwardConfig(PortletRequestProcessor.java:478)
              at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:241)
              at com.liferay.portal.struts.PortletRequestProcessor.process(PortletRequestProcessor.java:234)
              at com.liferay.portlet.StrutsPortlet.include(StrutsPortlet.java:296)
              at com.liferay.portlet.StrutsPortlet.doView(StrutsPortlet.java:157)
              at com.liferay.portal.kernel.portlet.LiferayPortlet.doDispatch(LiferayPortlet.java:213)
              at javax.portlet.GenericPortlet.render(GenericPortlet.java:233)
              at com.liferay.portlet.FilterChainImpl.doFilter(FilterChainImpl.java:103)
              at com.liferay.portlet.ScriptDataPortletFilter.doFilter(ScriptDataPortletFilter.java:55)
              at com.liferay.portlet.FilterChainImpl.doFilter(FilterChainImpl.java:100)
              at com.liferay.portal.kernel.portlet.PortletFilterUtil.doFilter(PortletFilterUtil.java:64)
              at com.liferay.portlet.InvokerPortletImpl.invoke(InvokerPortletImpl.java:618)
              at com.liferay.portlet.InvokerPortletImpl.invokeRender(InvokerPortletImpl.java:677)
              at com.liferay.portlet.InvokerPortletImpl.render(InvokerPortletImpl.java:379)
              at org.apache.jsp.html.portal.render_005fportlet_jsp._jspService(render_005fportlet_jsp.java:1242)
              at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
              at com.liferay.portal.servlet.DirectRequestDispatcher.include(DirectRequestDispatcher.java:57)
              at com.liferay.portal.servlet.ClassLoaderRequestDispatcherWrapper.doDispatch(ClassLoaderRequestDispatcherWrapper.java:78)
              at com.liferay.portal.servlet.ClassLoaderRequestDispatcherWrapper.include(ClassLoaderRequestDispatcherWrapper.java:53)
              at com.liferay.portlet.PortletContainerImpl._doRender(PortletContainerImpl.java:652)
              at com.liferay.portlet.PortletContainerImpl.render(PortletContainerImpl.java:138)
              at com.liferay.portlet.SecurityPortletContainerWrapper.render(SecurityPortletContainerWrapper.java:141)
              at com.liferay.portlet.RestrictPortletContainerWrapper.render(RestrictPortletContainerWrapper.java:126)
              at com.liferay.portal.kernel.portlet.PortletContainerUtil.render(PortletContainerUtil.java:156)
              at com.liferay.portal.layoutconfiguration.util.PortletRenderer._render(PortletRenderer.java:120)
              at com.liferay.portal.layoutconfiguration.util.PortletRenderer.access$4(PortletRenderer.java:107)
              at com.liferay.portal.layoutconfiguration.util.PortletRenderer$PortletRendererCallable.doCall(PortletRenderer.java:174)
              at com.liferay.portal.layoutconfiguration.util.PortletRenderer$PortletRendererCallable.doCall(PortletRenderer.java:1)
              at com.liferay.portal.kernel.executor.CopyThreadLocalCallable.call(CopyThreadLocalCallable.java:69)
              at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
              at java.util.concurrent.FutureTask.run(FutureTask.java:166)
              at com.liferay.portal.kernel.concurrent.ThreadPoolExecutor$WorkerTask._runTask(ThreadPoolExecutor.java:682)
              at com.liferay.portal.kernel.concurrent.ThreadPoolExecutor$WorkerTask.run(ThreadPoolExecutor.java:593)
              at java.lang.Thread.run(Thread.java:722)
      
      22:43:02,627 ERROR [RuntimePageImpl-16][IncludeTag:129] Current URL /web/so-site1/home generates exception: Unable to compile class for JSP: ____An error occurred at line: 27 in the jsp file: /html/portlet/bookmarks/view.so-hook.jsp__preferences cannot be resolved__24: __25: BookmarksFolder folder = (BookmarksFolder)request.getAttribute(WebKeys.BOOKMARKS_FOLDER);__26: __27: long defaultFolderId = GetterUtil.getLong(preferences.getValue("rootFolderId", StringPool.BLANK), BookmarksFolderConstants.DEFAULT_PARENT_FOLDER_ID);__28: __29: long folderId = BeanParamUtil.getLong(folder, request, "folderId", defaultFolderId);__30: ______An error occurred at line: 76 in the jsp file: /html/portlet/bookmarks/view.so-hook.jsp__The method getEntriesOrderByComparator(String, String) is undefined for the type BookmarksUtil__73: >__74: __75:     <%__76:         OrderByComparator orderByComparator = BookmarksUtil.getEntriesOrderByComparator("name", "asc");__77:    %>__78: __79:   <liferay-ui:search-container-results______Stacktrace: [Sanitized]
      org.apache.jasper.JasperException: Unable to compile class for JSP: ____An error occurred at line: 27 in the jsp file: /html/portlet/bookmarks/view.so-hook.jsp__preferences cannot be resolved__24: __25: BookmarksFolder folder = (BookmarksFolder)request.getAttribute(WebKeys.BOOKMARKS_FOLDER);__26: __27: long defaultFolderId = GetterUtil.getLong(preferences.getValue("rootFolderId", StringPool.BLANK), BookmarksFolderConstants.DEFAULT_PARENT_FOLDER_ID);__28: __29: long folderId = BeanParamUtil.getLong(folder, request, "folderId", defaultFolderId);__30: ______An error occurred at line: 76 in the jsp file: /html/portlet/bookmarks/view.so-hook.jsp__The method getEntriesOrderByComparator(String, String) is undefined for the type BookmarksUtil__73: >__74: __75:      <%__76:         OrderByComparator orderByComparator = BookmarksUtil.getEntriesOrderByComparator("name", "asc");__77:    %>__78: __79:   <liferay-ui:search-container-results______Stacktrace: [Sanitized]
              at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:103)
              at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:366)
              at org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:468)
              at org.apache.jasper.compiler.Compiler.compile(Compiler.java:378)
              at org.apache.jasper.compiler.Compiler.compile(Compiler.java:353)
              at org.apache.jasper.compiler.Compiler.compile(Compiler.java:340)
              at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:646)
              at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:357)
              at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
              at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
              at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:116)
              at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilter.doFilter(InvokerFilter.java:96)
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
              at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:749)
              at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:605)
              at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:544)
      

        Activity

        mandy.zia added a comment -

        PASSED Manual Testing following the steps in the description

        Fixed on:
        Tomcat 7 + MySQL 5. Portal 6.2.0 CE GA1.
        Plugins 6.2.X CE Git ID: 438e3250dc123b9b7ebb5a5aed098638361f5d00.

        Committed at:
        Plugins 6.2.X EE Git ID: bf5b35eef2bd632b88e61aa97b216c4a3fdbc52a.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response:
              Days since last comment:
              1 year, 15 weeks, 2 days ago

              Development

                Structure Helper Panel