PUBLIC - Liferay Social Office Community Edition
  1. PUBLIC - Liferay Social Office Community Edition
  2. SOS-2076

Editing a task with progress and assigning it to another user does not give that user a notification

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.X EE, 3.X CE
    • Fix Version/s: 3.X CE, 3.0.1 EE
    • Labels:
      None
    • Environment:
      Tomcat 7.0.42 + MySQL 5.5 Portal 6.2.0 CE GA1
      Plugins 6.2.x ee-6.2.x GIT ID: 4809d3f7e7f6d30b2380a3f3d963fe609c82e66c.
    • Fix Priority:
      4
    • Affects Portal Version/s:
      6.2.0 CE GA1
    • Similar Issues:
      Show 4 results 
    • Portal Fix Version/s:
      6.2.0 CE GA1, 6.2.10 EE GA1

      Description

      If a user creates a task, adds progress by clicking on the bar, and then assigns it to a new user, the user will not be notified.

      Steps to reproduce:
      1. Create a new task
      2. Click on the progress bar to add progress (example: 40%)
      3. Edit the task
      4. Switch the task to another user
      5. Login as the other user > Assert that the task was assigned to you without any notifications.

      Expected result:
      Any time a task is assigned to you, you should get a notification

      Actual result:
      If the task is made, then progress added, then edit to change the user, the new user will not get a notification.

      NOTE: In my testing, notifications worked as expected if a user was assigned the task right away, or the task user was edited before progress was made. The issue was only reproduced if the issue was created, then progress was added, then it was edited to change the user.

        Activity

        Ken Duenwald added a comment -

        PASSED Manual Testing following the steps in the description.

        Fixed on:
        Tomcat 7.0.42 + MySQL 5. Portal 6.2.0 CE GA1.
        Plugins 6.2.x CE GIT ID: e09ca932ad3ddf8dc5936165a0ce64dbc63c802a.
        Tomcat 7.0.42 + MySQL 5. Portal 6.2.10 EE GA1.
        Plugins 6.2.x EE GIT ID: 88e90d2f7181dfd42dcd44c883fff5222a314811.

        The user now receives a notification after step 5.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response:
              Days since last comment:
              1 year, 3 days ago

              Development

                Structure Helper Panel