PUBLIC - Liferay Social Office Community Edition
  1. PUBLIC - Liferay Social Office Community Edition
  2. SOS-2087

Invite members portlet role selection shows the role name instead of the title

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.3 EE, 2.0.4 EE GA2, 2.0.5 EE, 2.1.0 EE GA3, 3.X EE
    • Fix Version/s: 3.X CE, 3.0.1 EE, 3.1.0 CE
    • Labels:
    • Environment:
      LIFERAY VERSION: 7.0 (master)
      OPERATING SYSTEM: Windows7
      APPLICATION SERVER: Tomcat 7.0.x
      JAVA VIRTUAL MACHINE: Java 6
      DATABASE: MYSQL 5.1
    • Fix Priority:
      4
    • Affects Portal Version/s:
      6.1.20 EE GA2
    • Similar Issues:
      Show 5 results 
    • Portal Fix Version/s:
      6.2.x

      Description

      Reproduction steps:

      1) Build and deploy the SO plugin. Note: so-portlet requires contacts-portlet, marketplace-portlet, microblogs-portlet
      2) Add the Invite Members to a Site
      3) Change the language to German
      4) Add a German translation to the (i.e.) Site Administrator role, for example: "Site Administrator German"
      4+1) Check if you change the language to German, you can see the German translation in the Roles list
      6) Go to the Invite Members portlet (in German of course) and try to add a member and select a role

      Results: The role name is English, I guess it displays the Role's Name, which is not localized. I think it should display the Role's Title

        Activity

        Ken Duenwald added a comment -

        PASSED Manual Testing following the steps in the description.

        Fixed on:
        Tomcat 7.0.42 + MySQL 5. Portal 6.2.0 CE GA1.
        Plugins 6.2.x CE GIT ID: d1956d0f4097ebfafa7787e79ab274afd586a1ac.
        Tomcat 7.0.42 + MySQL 5. Portal 6.2.10 EE GA1.
        Plugins 6.2.x EE GIT ID: da5ba027a6b804c11b4498ce27ce2363259fd6d2.

        The German role name ("Site Administrator German") now appears at step 6.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response:
              Days since last comment:
              1 year, 24 weeks, 4 days ago

              Development

                Structure Helper Panel