Uploaded image for project: 'PUBLIC - Liferay Social Office Community Edition'
  1. PUBLIC - Liferay Social Office Community Edition
  2. SOS-2161

Some actions such as adding a new thread will seem to do nothing when my browser and app server is on different machines

    Details

    • Fix Priority:
      3

      Description

      Some actions such as adding a new thread will seem to do nothing when my browser and app server is on different machines.

      1. Make sure that the app server and the browser you are using are on different machines.
      2. Access liferay at http://[ip of server]:8080
      3. Log in and give your user the SO role.
      4. Create a new site.
      5. Go to the Forums page.
      6. Click to add a new thread.
        • Nothing happens.
      7. Click to add a new category.
        • Nothing happens.
      8. Go to the Blogs page.
      9. Add a new blog entry.
      10. Click on Publish to publish the entry.
        • A green success message appears at the top of the portlet, but instead of redirecting you to the published entry, you are still on the edit screen.

      Expected result: Each of the action should complete and lead to the next step.

      Actual result: Some buttons will do nothing, while some actions do not redirect correctly.

      Note: If the virtual host field in the portal instance configuration is updated to the ip of where the app server is located, these issues are no longer reproducible.

        Attachments

          Activity

            People

            Assignee:
            support-lep@liferay.com SE Support
            Reporter:
            mandy.lee Mandy Lee (Inactive)
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Days since last comment:
              6 years, 37 weeks, 6 days ago

                Packages

                Version Package