Uploaded image for project: 'PUBLIC - Liferay Social Office Community Edition'
  1. PUBLIC - Liferay Social Office Community Edition
  2. SOS-2399

Social Office Dashboard is not displayed properly if the user does not have the Power User role

    Details

    • Fix Priority:
      4
    • Affects Portal Version/s:
      Master, 6.2.x, 6.2.10 EE GA1

      Description

      Reproduction steps:

      1.) Install a vanilla 6.2 EE SP5 bundle.
      2.) Deploy Social Office EE 3.0.2.
      3.) Go to Control Panel --> License Manager and register your SO.
      4.) Stop your Tomcat and then restart it to make SO to be able to start.
      5.) Log in with the test@liferay.com account.
      6.) Create a new standard user "user1" with a password and remove its Power User role.
      7.) Go to Social Office Configurations and assign the User to the SO.
      8.) Go to Messages and send a new message to user1.
      9.) Login with user1, the Welcome page shows the Chat portlet and the red indicator at the top right, that the user has got a new message.
      10.) Open the Dashboard

      Result: The Chat portlet and the message indicator are hidden and everything is displayed with a red background with the "You do not have the roles required to access this portlet" message.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                5 years, 7 weeks, 2 days ago

                Packages

                Version Package
                3.X EE
                3.X CE
                3.1 EE