Uploaded image for project: 'PUBLIC - Liferay Social Office Community Edition'
  1. PUBLIC - Liferay Social Office Community Edition
  2. SOS-2518

Console errors when upgrading from SO 3.1.0 EE to latest ee-6.2.x plugins

    Details

    • Type: Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 3.X EE, 3.1 EE
    • Fix Version/s: 3.X EE
    • Component/s: Environment
    • Labels:
      None
    • Fix Priority:
      5

      Description

      Console errors are thrown when upgrading from Social Office 3.1.0 EE to the latest Social Office plugins at head (3.X).

      Some functionality is lost, such as the Microblogs Status Update portlet becomes unavailable after upgrade.

      Steps to reproduce.

      1. Deploy SO 3.1.0 onto a 6.2.x bundle using the database "lportal"
      2. Assert that the portal starts up and SO deploys without errors.
      3. Shut down the app server
      4. Deploy SO 3.X (latest plugins) onto a new 6.2.x bundle using the same database.
      5. After upgrade finishes, navigate to the portal in a browser and assert console errors.
      6. Assert Dashboard > Microblogs Status Update portlet is unavailable

      Expected results:

      Deploying new plugins should automatically upgrade to the latest version of SO without errors.

      Actual results:

      Deploying the new plugins causes console errors and portions of the Microblogs portlet to become unavailable.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  5 years, 26 weeks ago

                  Packages

                  Version Package
                  3.X EE