Uploaded image for project: 'PUBLIC - Liferay Sync'
  1. PUBLIC - Liferay Sync
  2. SYNC-1052

Sync does not recover connection after changing passwords

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: No Longer Reproducible
    • Affects Version/s: 1.1.1 GA1
    • Fix Version/s: None
    • Component/s: General
    • Labels:
      None
    • Environment:
      All

      Description

      I think I found a way to reproduce it. The problem is related to authentication issues. http://in.liferay.com was having authentication issues today and Sync couldn't recover from the disconnected state, even when it's restarted, it goes to a dead state.
      You can use localhost to reproduce this issue, it doesn't need to be in.liferay.com.
      1. Start Sync.
      2. Change your password on the portal from "test" to something else.
      3. Restart Sync, since you haven't changed Sync's password, it will get an unauthorized exception and it will stay as disconnected, this is the expected behavior and that's a simulation of what happened earlier with in.liferay.com.
      4. Change your password on the portal back to "test".
      5. Restart Sync. Now, here's the bug: even though the passwords are matching again, Sync can't connect and stays disconnected forever. I haven't found a workaround, I guess I would need to reinstall Sync or create a new Sync folder and type my credentials again.
      I think this bug has a different root cause but hasn't been caught before.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  5 years, 45 weeks, 5 days ago

                  Packages

                  Version Package