Uploaded image for project: 'PUBLIC - Liferay Sync'
  1. PUBLIC - Liferay Sync
  2. SYNC-1226

Liferay Sync does not work with Portal 6.1 with PostgreSQL, Oracle and DB2

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0 GA1
    • Fix Version/s: 1.2.1 GA2
    • Component/s: General
    • Labels:
      None
    • Affects Portal Version/s:
      6.1.20 EE GA2

      Description

      https://www.liferay.com/group/customer/support/-/support/ticket/BOEGOLD-25

      Reproduction steps:

      1.) Install a vanilla Liferay 6.1.20 bundle with PostgreSQL 8.4 DB Connection (I tested with 9.3 version and obtained the same error), the portal-ext.properties file should have the following structure:

      jdbc.default.driverClassName=org.postgresql.Driver
      jdbc.default.url=jdbc:postgresql://localhost:5432/boegold25
      jdbc.default.username=postgres
      jdbc.default.password=password
      

      2.) Start Liferay Sync.

      Result: In the Liferay log you get the following error:

      org.postgresql.util.PSQLException: ERROR: timestamp out of range: "292278994-08-17 07:12:55.807000 +00:00:00"
      

      In the liferay-sync.log the following error message appears:

      ERROR [BaseEvent:115] Received exception response class com.liferay.sync.modules.documentlibrary.server.remote.v6_1.event.GetLatestModifiedTimeEvent_v6_1 {"exception":"com.liferay.portal.kernel.exception.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.DataException: could not execute query"}
      

      Thank you for your cooperation.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                5 years, 37 weeks, 5 days ago

                Packages

                Version Package
                1.2.1 GA2