Uploaded image for project: 'PUBLIC - Liferay Portal Web Content Experience'
  1. PUBLIC - Liferay Portal Web Content Experience
  2. WCM-318

Upload doesn't complete when importing Site LAR with Audience Targeting data

    Details

    • Fix Priority:
      3

      Description

      Steps to reproduce:

      1. Add a User Segment
      2. Add a Web Content article with the User Segment categorized to it
      3. Add a page
      4. Add a User Segment Content Display portlet and configure it to display the User Segment
      5. Navigate to Admin > Site Administration: Pages
      6. Export the Site
        • During Export, change the select option to 'Choose Applications', and click the 'Change' link under User Segment Content Display
        • Unflag 'Referenced Content' in the pop-up and Save
        • Click Publish (see that it says 'Successful')
      7. Create a new Site
      8. Upload the exported Site LAR to this new Site

      Expected result:
      Upload will finish and user can finish Importing the LAR.

      Actual result:
      Upload continues indefinitely, and a JavaScript error, "TypeError: str is undefined" is thrown in firebug. See attached gif.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Packages

                  Version Package