Uploaded image for project: 'PUBLIC - Liferay Portal Web Content Experience'
  1. PUBLIC - Liferay Portal Web Content Experience
  2. WCM-598

Error message always appears when creating a Custom Report with a Content field

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 2.x
    • Fix Version/s: 2.0
    • Component/s: Content Targeting
    • Labels:
      None

      Description

      Steps to reproduce:

      1. Add a Campaign
      2. Click to view the Campaign > Click the Reports tab
      3. Click + to add a Custom Report
      4. Drag the Content field to the form builder

      Expected result:
      Since the Content field tracking Analytics are enabled by default, the error message shouldn't display when viewing the field's expanded panel.

      Actual result:
      The warning message disappears for all other fields when enabling their tracking actions. But the Content field still shows the message: "This metric will not work properly because content tracking is not enabled. It can be enabled in Control Panel > Portal Settings > Audience Targeting Analytics or in Site Administration > Site Settings > Audience Targeting Analytics."

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: